GOAT logo

Join the conversation! The forum activity is now at GOATeach.org!  We are working to cross pollinate our conversations. Document and share tools at farm hack and talk at GOAT!  Also join GOAT riot and introduce yourself and your projects!

Bug - editing crashed when uploading jpg to root washer tool

Topic Type: 

Tried to add new image to root washer entry - and page lost all forms after upload button was hit.

Louis's picture

I've noticed this issue too when uploading files although I was able to recover my text when I hit the back button. I tried multiple times until it went through and eventually it worked...

I have no idea what could be causing it but RJ might have an idea when he has a minute!

R.J. Steinert's picture

Sorry to hear you guys are having troubles. It sounds like this is happening when you: 1. Click "choose file" 2. Select the file from you harddrive 3. Click Save at the bottom of the Form.

Is that correct? It is safer to do the uploading of the file and the saving of the form in separate steps in case the server has a hiccup or your connection is momentarily slow. As a best practice I recommend uploading images using the following steps. 1. Click "choose file" 2. Select the file from you harddrive 3. Click the "Upload" button next to File you just selected on the Form. 4. Wait for the upload to finish. 5. Click Save at the bottom of the Form.

I just performed the first operation I described above on the Root Washer and everything went OK. I did however run into a new bug, if you edit the Root Washer's profile and click "Remove" on the current image, the whole form disappears!